Domanda Casablanca: errore di assemblaggio gcc 4.8.1 su linux centos


Sto cercando di costruire casablanca, come dicono su la loro pagina. Perchè ho gcc-4.8.1 installato usando CXX=gcc-4.8 non è ok, quindi l'ho rimosso facendo solo:

cmake .. -DCMAKE_BUILD_TYPE=Release

Crea i file e quando lo faccio make Sto ottenendo questi errori:

Scanning dependencies of target casablanca
[  1%] Building CXX object src/CMakeFiles/casablanca.dir/streams/linux/fileio_linux.cpp.o
/tmp/ccoWLl81.s: Assembler messages:
/tmp/ccoWLl81.s:97: Error: expecting string instruction after `rep'
/tmp/ccoWLl81.s:188: Error: expecting string instruction after `rep'
/tmp/ccoWLl81.s:298: Error: expecting string instruction after `rep'
/tmp/ccoWLl81.s:310: Error: expecting string instruction after `rep'
/tmp/ccoWLl81.s:322: Error: expecting string instruction after `rep'
/tmp/ccoWLl81.s:334: Error: expecting string instruction after `rep'
/tmp/ccoWLl81.s:371: Error: expecting string instruction after `rep'
/tmp/ccoWLl81.s:494: Error: expecting string instruction after `rep'
/tmp/ccoWLl81.s:508: Error: expecting string instruction after `rep'
/tmp/ccoWLl81.s:522: Error: expecting string instruction after `rep'
/tmp/ccoWLl81.s:536: Error: expecting string instruction after `rep'
/tmp/ccoWLl81.s:550: Error: expecting string instruction after `rep'
/tmp/ccoWLl81.s:2028: Error: expecting string instruction after `rep'
/tmp/ccoWLl81.s:2057: Error: expecting string instruction after `rep'
/tmp/ccoWLl81.s:2086: Error: expecting string instruction after `rep'
/tmp/ccoWLl81.s:3975: Error: expecting string instruction after `rep'
/tmp/ccoWLl81.s:6186: Error: expecting string instruction after `rep'
/tmp/ccoWLl81.s:10355: Error: expecting string instruction after `rep'
make[2]: *** [src/CMakeFiles/casablanca.dir/streams/linux/fileio_linux.cpp.o] Error 1
make[1]: *** [src/CMakeFiles/casablanca.dir/all] Error 2
make: *** [all] Error 2

Qualcuno ha incontrato questo problema? È a causa di gcc4.8.1? Come sistemarlo?


10
2018-05-09 09:30


origine


risposte:


Il problema è che gcc 4.8 sta generando istruzioni "rep; ret" per evitare una penalizzazione delle prestazioni dei chip AMD. I vecchi assemblatori lo riconoscono come un errore.

I dettagli sono qui:

https://gcc.gnu.org/ml/gcc-help/2011-03/msg00286.html

La soluzione è aggiornare i tuoi binutils in modo da ottenere una versione più recente di un assemblatore che accetta queste istruzioni.


15
2017-07-08 06:32



sudo yum update binutils

---> Pacchetto binutils.x86_64 0: 2.22.52.0.1-10.36.amzn1 verrà aggiornato

---> Pacchetto binutils.x86_64 0: 2.23.52.0.1-30.64.amzn1 sarà un aggiornamento


4
2017-10-09 09:31