Domanda Versione Bluetooth su iMac


Come posso sapere quale versione di Bluetooth è stata installata (ad esempio 2.1 + EDR o 4.0)? Ho scaricato Bluetooth Explorer e sono andato in giro, ma non vedo alcuna informazione che mi urti "Versione Bluetooth". Né ho potuto trovare alcun dato di modello di mappatura online dei dati per le versioni Bluetooth.

Lo chiedo perché sto cercando di fare un po 'di lavoro con i profili 4.0 LE. Il mio Mac è un "iMac11,2".


10
2018-06-22 20:30


origine


risposte:


System Profiler (apple> su questo mac> maggiori informazioni> system report> hardware> bluetooth) ti dirà la tua "versione LMP"

cerca qui la versione di LMP http://www.bluetooth.org/Technical/AssignedNumbers/link_manager.htm

I principali sono:

Versione LMP -> Versione BT

4 -> Bluetooth Core Specification 2.1 + EDR

6 -> Bluetooth Core Specification 4.0


31
2017-08-03 22:26



1.  Click the  menu.
2.  Select About This Mac.
3.  Click on the More Info... button.
4.  Click on the System Report... button.
5.  Select Bluetooth from the sidebar on the left, underneath "Hardware."
6.  Scan down the list of information until you find "LMP Version."

Se il tuo Mac è dotato di Bluetooth 4.0, la versione di LMP dirà 0x6. Qualunque cosa inferiore a questa è una versione precedente di Bluetooth

Fonte: http://www.imore.com/how-tell-if-your-mac-has-bluetooth-40


3
2018-06-24 17:47



Informazioni trovate sull'hardware Qui googling su "specifiche iMac11,2". Sembra che sia Bluetooth 2.1 + EDR dopo tutto. (Ha senso, visto che è un modello a metà del 2010).

Non riesco ancora a capire se c'è un modo per divinarlo in Bluetooth Explorer.


1
2017-07-09 17:47



L'unico elemento elencato in un'altra risposta non funziona per me perché la mia versione LMP viene riportata come numero esadecimale anziché come numero decimale (0x6 anziché solo 6). Tuttavia, può essere modificato per funzionare indipendentemente dal fatto che sia decimale o esadecimale, sostituendo lo spazio prima del numero 6 con ". *". Ecco la one-liner modificata che dovrebbe funzionare per tutti i casi:

system_profiler -detailLevel full SPBluetoothDataType | grep -q "LMP Version:.*6" && echo "Your Mac is supported" || echo "Your Mac is not supported"

1
2017-11-07 03:12



Una fodera:

system_profiler -detailLevel full SPBluetoothDataType | grep -q "LMP Version: 6" && echo "Your Mac is supported" || echo "Your Mac is not supported"

0
2017-07-17 02:21