Domanda Ottenere l'errore "Nessun repository trovato" in Eclipse (Ganymede) durante il tentativo di installare i plug-in di google (GWT)


Sto cercando di installare Google Web Toolkit per Eclipse (Ganimede) e sto ricevendo il seguente errore.

An error occurred while collecting items to be installed
  No repository found containing: org.eclipse.emf.common/osgi.bundle/2.4.0.v200808251517
  No repository found containing: org.eclipse.emf.ecore/osgi.bundle/2.4.1.v200808251517
  No repository found containing: org.eclipse.emf.ecore.change/osgi.bundle/2.4.0.v200808251517
  No repository found containing: org.eclipse.emf.ecore.edit/osgi.bundle/2.4.1.v200808251517
  No repository found containing: org.eclipse.emf.ecore.xmi/osgi.bundle/2.4.1.v200808251517
  No repository found containing: org.eclipse.emf.edit/osgi.bundle/2.4.1.v200808251517
  No repository found containing: org.eclipse.wst.common.emf/osgi.bundle/1.1.202.v200809111955
  No repository found containing: org.eclipse.wst.common.emfworkbench.integration/osgi.bundle/1.1.201.v200808071700
  No repository found containing: org.eclipse.wst.common.frameworks/osgi.bundle/1.1.200.v200805140020
  No repository found containing: org.eclipse.wst.common.project.facet.core/osgi.bundle/1.3.3.v200809102124
  No repository found containing: org.eclipse.wst.sse.core/osgi.bundle/1.1.302.v200808260045
  No repository found containing: org.eclipse.wst.sse.ui/osgi.bundle/1.1.2.v200809120159
  No repository found containing: org.eclipse.wst.validation/osgi.bundle/1.2.2.v200809050219
  No repository found containing: org.eclipse.wst.xml.core/osgi.bundle/1.1.305.v200809120354

Cosa potrebbe significare questo errore e come installare i plugin. È una nuova installazione di Eclipse e Vista a 64 bit. Ero solito "http://dl.google.com/eclipse/plugin/3.4"come la posizione del plugin di Google.


12
2017-07-09 08:50


origine


risposte:


Ho avuto questo problema oggi. ho trovato questo link utile che ha aiutato. Fondamentalmente assicurati che tutti gli URL delle tue fonti finiscano in una barra (/) e aggiungili se mancano.

Ho anche visitato tutti i siti e fatto clic sul pulsante Test Connection (penso sia quello che viene chiamato) su ciascuno di essi per vedere se c'era qualcosa di sbagliato e tutti hanno restituito un risultato positivo.

Dopodiché, improvvisamente sono stato in grado di installare le funzionalità e i plug-in che non erano riusciti con gli errori "Nessun repository trovato" prima.


23
2018-04-08 05:43



Ok ho capito.

Avevo installato Eclipse Classic e non mi piaceva. Da allora, ho disinstallato il classico e installato "Eclipse Java EE" e l'aggiornamento ha funzionato.


7
2017-07-10 12:24



Nel mio caso, ho dei siti di software di archiviazione che sono stati cancellati e l'aggiornamento dice di questo. Dai un'occhiata Windows -> Preferenze -> Siti software disponibili. In questo elenco non dovrebbe essere siti di archivio stregati cancellati. Poi riavviare eclissi.


6
2018-06-23 07:08



Ho appena pulito eclissi e l'ho eseguito funzionante. nel prompt dei comandi digitare eclipse -clean

Questo pulisce l'installazione di Eclipse e aiuta a correre


2
2018-06-09 15:22



Non necessariamente per fare tutte quelle esportazioni e cose importanti. Eclipse ha un problema con se stesso. Ma può essere risolto con un semplice avvio di

cmd> eclipse.exe -clean

ci vorrà un po 'per l'avvio, ma alla fine ha funzionato per me. coz parzialmente a volte eclissi ha problemi nel decomprimere i file o così n file parziali decompressi.


2
2018-02-28 07:01



Ho avuto lo stesso problema, ciò che è stato risolto modificando il sistema di aggiornamento utilizzato da Eclipse. Sto usando Eclipse 3.5 e il sistema di aggiornamento predefinito è P2 (http://wiki.eclipse.org/Equinox_p2_Getting_Started). Prova a selezionare Preferimenti-> Generale-> Funzionalità-> seleziona la casella accanto a Aggiornamento classico. Questo l'ha risolto per me.


1
2017-08-14 22:28



Sembra che il tuo specchio di eclissi sia corrotto. Usane un altro.


0
2017-07-10 07:23



Ho ricevuto questo errore durante il tentativo di aggiornare il plug-in di Google (facendo clic sul popup "aggiornamenti disponibili").

Rivedere i miei siti di aggiornamento, si è scoperto che il principale Sito di aggiornamento di Google (Http://dl.google.com/eclipse/plugin/3.5) mancava, anche se dubito di averlo rimosso. Semplicemente aggiungere nuovamente ha risolto il problema.


0
2018-05-18 16:03