Domanda È richiesta la versione Gradle 2.10. La versione corrente è 2.8 Errore


Le seguenti cose stanno usando nel progetto-

La versione di Android Studio 2.0 Anteprima 4.
  ANDROID_BUILD_MIN_SDK_VERSION = 9
  ANDROID_BUILD_TARGET_SDK_VERSION = 22
  ANDROID_BUILD_TOOLS_VERSION = 22.0.1
  ANDROID_BUILD_SDK_VERSION = 22

classpath 'com.android.tools.build:gradle:2.0.0-alpha9'

Come per l'errore ho cambiato l'url di distribuzione

https\://services.gradle.org/distributions/gradle-2.8-all.zip

a

https\://services.gradle.org/distributions/gradle-2.10-all.zip

ma continua a ricevere il seguente errore

Errore: (1, 1) Si è verificato un problema durante la valutazione del progetto ': app'.   Impossibile applicare il plug-in [id 'com.android.application']   È richiesta la versione Gradle 2.10. La versione attuale è 2.8. Se si utilizza il wrapper gradle, provare a modificare distributionUrl in /Users/manishpathak/Project/live/code/ICCCricketWorldCup2015Schedule/gradle/wrapper/gradle-wrapper.properties a gradle-2.10-all.zip


13
2018-02-02 12:08


origine


risposte:


aggiorna la tua versione di Android Studio alla 1.5.1. Il tuo problema sarà risolto. Se la tua versione di Android è aggiornata. Provalo:

modificare Impostazioni> Build, Execution, Deployment> Build Tools> Gradle> Gradle home path O

set Usa il wrapper gradle predefinito e modifica Project \ Gradle \ involucro \ gradle-wrapper.properties campo di file distributionUrl come questo:

distributionUrl=https://services.gradle.org/distributions/gradle-2.10-all.zip

prova questo


11
2018-02-02 12:17



Hai solo bisogno di aggiornare il percorso per la directory gradle da gradle-2.8 a gradle-2.10

passi:

Clicca su file -> impostazioni -> gradle

Scegli il pulsante di opzione "Utilizza la distribuzione gradle locale" nelle impostazioni a livello di progetto

apri e incolla il percorso della directory di gradle-2.10

(Nota: Path sarà simile a dove gradle-2.8 era presente in precedenza se hai fatto qualche aggiornamento per Android Studio, altrimenti devi menzionare il percorso della directory di download se hai scaricato la distribuzione gradle standalone da http://gradle.org/gradle-download/ )

cambia il gradle 2.8 al gradle 2.10 in file -> settings -> gradle

Applicare le impostazioni e ricostruire il progetto.

enter image description here


7
2018-06-03 07:32



opzione 1

Primo tentativo: Aggiorna il file gradle-wrapper.properties che si trova in [Project \ gradle \ wrapper \ gradle-wrapper.properties] update distributionUrl distributionUrl = https: //services.gradle.org/distributions/gradle-2.10-all.zip

se sopra non funziona, segui anche i seguenti passaggi

opzione 2

Passo 1:  Controlla la versione gradle: Gradle generalmente è installato nella cartella: C: \ Programmi \ Android \ Android Studio \ gradle \ gradle [numero di versione] es. Gradle-4.1

Passo 2:  aggiorna gradle è installato, scarica il gradle da https://services.gradle.org/distributions/ per te scaricalo https://services.gradle.org/distributions/gradle-2.10-bin.zip e posizionarlo nella cartella gradle di Studio o in altri dove

fase 3: aggiorna percorso gradle per (progetto specifico o globale come richiesto) File> Impostazioni> Build, Esecuzione, Distribuzione> Strumenti di costruzione> Gradi> Percorso home Gradle enter image description here

Opzione 3 File> Struttura del progetto> Progetto> Versione Gradle, cambiarla in 2.10 enter image description here


4
2017-07-24 10:24



per questa domanda modificare File> Struttura del progetto> Progetto> Versione Gradle da 2,8 a 2,10 solo così


3
2018-04-15 10:39