Domanda Impossibile risolvere: Errore: (23, 17) junit: junit: 4.12 in Android Studio 1.4 [duplicato]


Questa domanda ha già una risposta qui:

Utilizzo Android Studio 1.4 e ogni volta che creo un nuovo progetto, si verifica lo stesso errore

Error:(23, 17)"Failed to resolve: junit:junit:4.12".

Ho letto post precedente sullo stesso problema
Errore: (23, 17) Impossibile risolvere: junit: junit: 4.12

e fatto tutta la risposta data, ma nonostante l'aggiunta di URL ('http://repo1.maven.org/maven2' e 'http://jcenter.bintray.com/') per il repository mancante rimane l'errore

ecco il mio ultimo codice build.gradle

apply plugin: 'com.android.application'

android {
  compileSdkVersion 14
  buildToolsVersion "23.0.1"

  defaultConfig {
    applicationId "com.example.myapplication"
    minSdkVersion 14
    targetSdkVersion 14
    versionCode 1
    versionName "1.0"
  }
  buildTypes {
    release {
        minifyEnabled false
        proguardFiles getDefaultProguardFile('proguard-android.txt'), 'proguard-rules.pro'
    }
  }
}

dependencies {
  compile fileTree(dir: 'libs', include: ['*.jar'])
  testCompile 'junit:junit:4.12'
  compile 'com.android.support:appcompat-v7:22.+'
}

13
2017-11-18 14:16


origine


risposte:


Se li aggiungi a buildscript otterrai un errore.

È una differenza tra il repository buildscript e i repository per le dipendenze. Il buildscript viene utilizzato per le dipendenze di build gradle.

Sarà necessario aggiungere quanto segue al file build.gradle e dovrebbe funzionare correttamente.

repositories {
    maven { url 'http://repo1.maven.org/maven2' }
    jcenter { url "http://jcenter.bintray.com/" }
}

In seguito dovrebbe funzionare:

apply plugin: 'com.android.application'

repositories {
    maven { url 'http://repo1.maven.org/maven2' }
    jcenter { url "http://jcenter.bintray.com/" }
}

android {
    compileSdkVersion 23
    buildToolsVersion "23.0.1"

    defaultConfig {
        applicationId "com.example.application"
        minSdkVersion 15
        targetSdkVersion 23
        versionCode 1
        versionName "1.0"
    }
    buildTypes {

        release {
            minifyEnabled false
            proguardFiles getDefaultProguardFile('proguard-android.txt'), 'proguard-rules.pro'
        }
    }
}

dependencies {
    compile fileTree(dir: 'libs', include: ['*.jar'])
    testCompile 'junit:junit:4.12'
    compile 'com.android.support:appcompat-v7:23.1.1'
    compile 'com.android.support:design:23.1.1'
}

28
2017-11-18 15:08



Per me era la sezione di tutti i progetti che mancava nel file di build gradle di primo livello:

buildscript {
    [...]
}

allprojects { // <-- required!!!
    repositories {
        jcenter()
    }
}

7
2018-02-26 21:42



  1. vai alla cartella android studio libs    (C:\Program Files\Android\Android Studio\lib) 
  2. trova junit-4.12.jar file
  3. copia il file jar nella cartella libs del progetto (myproject\app\libs)
  4. apri Android Studio ed elimina (commenta) questa riga    (testCompile 'junit:junit:4.12') in build.gradle file
  5. nella cartella android studio open (libs) e fai clic con il pulsante destro del mouse sul file jar, quindi scegli add as a library

  6. costruisci il tuo progetto (per maggiori informazioni vedi l'immagine qui sotto)

risolto errore: (23, 17) Impossibile risolvere: junit: junit: 4.12


4
2018-05-19 17:19