Domanda L'aggiornamento di un dispositivo su iOS 11.2 interrompe il supporto con Xcode 9.1


Ho provato a eseguire la mia app su un dispositivo con iOS 11.2 e ho ricevuto il seguente errore:

Impossibile individuare i file supportati dal dispositivo.

Questo iPhone 5s (modello A1457, A1518, A1528, A1530) esegue iOS 11.2   (15C114), che potrebbe non essere supportato da questa versione di Xcode.

Ho usato iphone 5s (versione 11.1.2) e voglio costruire il mio progetto da xcode 9.1 (ios 11.1).


18
2017-12-03 08:08


origine


risposte:


Sembra che Apple abbia rilasciato iOS 11.2 al pubblico senza rilasciare ancora Xcode 9.2 (il Mac App Store riporta 9.1 come più recente al momento della stesura di questo documento), che include l'SDK iOS 11.2 necessario per il targeting di dispositivi con iOS 11.2. Dovresti essere in grado di eseguirlo sul tuo dispositivo con la versione beta di Xcode 9.2, che puoi scaricare da pagina di download per sviluppatori se hai un account sviluppatore

MODIFICARE: Xcode 9.2 è ora disponibile al pubblico e puoi scaricarlo dal Mac App Store


17
2017-12-03 08:22



Xcode 9.2 è stato finalmente rilasciato. Puoi aggiornarlo dall'App Store o semplicemente scaricarlo qui: https://download.developer.apple.com/Developer_Tools/Xcode_9.2/Xcode_9.2.xip


2
2017-12-04 20:27



Ho Xcode9.2 sul mio MacBook e 8 sul mio MacMini. Quindi ho appena copiato 11.2 DeviceSupport DeveloperDiskImage .dmg e .signature dal MacBook al MacMini. Ha funzionato bene


1
2017-12-21 09:04



Per i principianti come me, se ottieni un messaggio simile a questo:

"Questo iPhone 6 utilizza iOS 11.2.X, che potrebbe non essere supportato da questa versione di Xcode."

Significa che devi aggiornare Xcode.

Ho riscontrato questo problema quando il mio telefono era in esecuzione 11.2.6 e stavo eseguendo Xcode versione 9.0

Puoi aggiornarlo dall'App Store o semplicemente scaricarlo qui: https://download.developer.apple.com/Developer_Tools/Xcode_9.2/Xcode_9.2.xip


0
2018-02-27 08:00



Ottieni il file di supporto del dispositivo da qui se disponibile File di supporto del dispositivo


0
2018-05-17 06:07



Qualcuno con questo tipo di errore quando la versione del sistema operativo del tuo dispositivo è aggiornata e la tua Xcode la versione non lo è.

enter image description here

Xcode - Versione 9.1 (9B55) Versione dispositivo - 11.3

Soluzione:

Trova i tuoi amici che hanno più tardi Xcode 9.x

Dai seguenti modi è possibile ottenere i file di supporto del dispositivo

  1. Vai a Finder e Cerca

/Applications/Xcode.app/Contents/Developer/Platforms/iPhoneOS.platform/DeviceSupport/

  1. Fare clic con il tasto destro su Xcode -> Mostra contenuto pacchetto quindi accedere a Contenuto / Sviluppatore / Piattaforme / iPhoneOS.platform / DeviceSupport / 11.X Copia il 11.X

notare che X - saranno versioni

Inoltre è possibile scaricare da questo link - https://github.com/filsv/iPhoneOSDeviceSupport/issues/7

Dopo aver ottenuto i file di supporto del dispositivo, aggiungi tutta la nuova versione al tuo Xcode DeviceSupport cartella

Riavvia Xcode e sei pronto per eseguire il debug :)


0
2018-05-22 09:52