Domanda Xcode 6 Beta iOS 8 Simulator non può accedere a Internet


Ho appena installato XCode 6 Beta per testare la mia app. Il simulatore di iOS 8 viene eseguito e la mia app viene installata correttamente ma il simulatore non può accedere a Internet. Cerco di utilizzare Safari o mappe e non c'è alcuna connessione di rete. Se eseguo il simulatore iOS 7 da XCode 6, si connette perfettamente a Internet.

Ho provato a utilizzare i passaggi in questo thread ma non ha cambiato nulla. (I passaggi erano più se la tua app non si installa ma ho provato comunque).

Non ho un firewall o un piccolo spia che blocchino il simulatore.

Qualche altra indicazione?

Maps doesn't connect to the internet safari no connection


23
2017-08-04 14:15


origine


risposte:


Ho avuto lo stesso problema. Prova ad uscire dal simulatore iOS, quindi ricostruisci e avvia la tua applicazione. Dovrebbe funzionare.


19
2017-10-23 17:44



Ho visto molti post su come riavviare il simulatore, reimpostare le impostazioni del simulatore, ecc. Alla fine ho reinstallato X-Code, aggiornando a X-Code 6.1, ecc. Ecc. Ancora non avevo una connessione al Rete!

Ciò che ha finito per essere la soluzione è che ho spento il mio antivirus (TrendMicro). Avevo controllato tutte le impostazioni anti-virus e non ho visto alcuna "connessione al processo di blocco". Quando ho disattivato il tutto, ho risolto il problema.


17
2017-10-24 18:36



Ho avuto lo stesso errore con il simulatore xCode 6.1 e iOS 8. Ciò che ha funzionato per me è andare alle impostazioni> sviluppatore> e attivare l'opzione "Consenti servizi HTTP".


6
2017-11-12 11:18



Lo stesso problema per la sicurezza avast su Mac, la disattivazione di webshield sotto le preferenze di avast l'ha risolto.

Xcode versione 7.3.1, ios simulator 8.4


5
2018-05-11 11:17



Disattivando AVAST risolvi tutti gli errori.


3
2018-05-12 21:29



Ho avuto lo stesso identico problema. È bizare ma collegare il mio Macbook tramite un cavo Ethernet sembra risolvere questo problema. So che non è perfetto ma funziona.


2
2017-08-04 14:19



Io uso anche XCode 6.1 GM e faccio lo stesso problema. Il mio scenario era che durante lo sviluppo collegavo il mio MacBook a un'altra WLAN. Il mio Macbook era connesso a Internet, ma il simulatore iOS no. La mia soluzione era quella di chiudere il simulatore iOS e ridistribuire l'app da xcode.


1
2017-10-08 17:09