Domanda Errore: impossibile trovare il modulo '@ ionic / app-scripts'


Sono nuovo di Ionic. Stavo seguendo la documentazione di Ionic "per iniziare", ho creato un esempio di progetto chiamato "super". Il problema è che quando eseguo la riga di comando ionic serve nella directory del progetto, ha generato un errore Error: Cannot find module '@ionic/app-scripts'


26
2018-06-06 04:20


origine


risposte:


script app attualmente compatibili con i nodi 6 e 7. Se hai installato il nodo 8, disinstalla e installa la versione stabile di node 6. Questo errore risolto e ora posso usare ionico 3, angolare 4. Stai attento!


19
2018-06-25 19:35



Prova a installare app-script da npm

npm i @ ionic / app-scripts


58
2018-06-06 05:05



Per ottenere l'ultimo @ionic/app-scripts, esegui il seguente comando:

npm install @ionic/app-scripts@latest --save-dev

14
2017-08-16 11:11



Stavo affrontando lo stesso problema, ecco cosa ho fatto-

  1. Rimosso node_modules dalla directory (manualmente).
  2. apri dir progetto
  3. esegui questo comando-

 npm install

Questo ha corretto quegli errori per me.

Vedere qui.


7
2017-09-05 10:29



Ho avuto questo problema, l'ho risolto eliminando node_modules / folder e ho eseguito il comando npm installora la mia app funziona


3
2018-06-26 05:49



non eseguire il downgrade della versione del nodo, aggiornare la versione di "app-scripts":

Per ottenere gli ultimi script @ ionic / app, esegui:

npm install @ionic/app-scripts@latest --save-dev

2
2018-06-13 20:53



Ho avuto il problema, risolto da esecuzione cnpm i @ionic/app-scripts.


0
2017-08-07 07:09